Tuesday, July 28, 2009

Scim error with OpenOffice 3.1


I was getting the following error when I pressed Ctrl + Space in OpenOffice window to initiate scim -

Gtk-WARNING **: /opt/openoffice.org3/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/gtk-2.0/immodules/im-scim.so)

After a bit of googling I found a solution -


cd /opt/openoffice.org3/basis-link/ure-link/lib

sudo mv libstdc++.so.6 libstdc++.so.6.orig
sudo ln -s /usr/lib/libstdc++.so.6.0.9 libstdc++.so.6

sudo mv libgcc_s.so.1 libgcc_s.so.1.orig
sudo ln -s /usr/lib/libgcc_s.so.1 libgcc_s.so.1




No comments: